SitePoint Sponsor

User Tag List

Results 1 to 7 of 7

Hybrid View

  1. #1
    SitePoint Wizard silver trophy Jelena's Avatar
    Join Date
    Feb 2005
    Location
    Universum, 3rd Corner
    Posts
    3,001
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Installation problem: PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_

    Hello all,

    This is not the first time I am installing Apache, PHP and MySQL db on my local machine, but this time it seems I cannot solve the problem mentioned in the title.

    Apache installation went fine. PHP installation went fine as well. Same is with MySQL.

    But the problem is with mcrypt library.

    PHP is located under C:\PHP where php.ini is as well.
    I added C:\PHP to system PATH and all other extensions work fine:
    extension=php_gd2.dll
    extension=php_mbstring.dll
    extension=php_mysql.dll
    extension=php_mysqli.dll

    Other relevant info from php.ini:
    extension_dir = "C:\PHP\ext"

    I DO have libmcrypt.dll in C:\PHP and php_mcrypt.dll in ext dir.

    I even tried to put dll in the system32 dir as suggested somewhere, but that didn't work as well.

    Any idea??

    Thanks,
    Jelena
    -- Jelena --

  2. #2
    SitePoint Enthusiast
    Join Date
    Dec 2003
    Location
    norway
    Posts
    61
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had a similar problem, however I could not solve it..
    Did you install EasyPHP? if not, try it, that worked for me to have a LAMP installation up and running

  3. #3
    SitePoint Wizard silver trophy Jelena's Avatar
    Join Date
    Feb 2005
    Location
    Universum, 3rd Corner
    Posts
    3,001
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    No, I went with downloading latest versions of Apache, PHP and MySQL, like I always did before. This is the first time I have a problem which I can't find the solution for anywhere!

    Thanks.
    -- Jelena --

  4. #4
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you checked that it is looking for the mcrypt file? Maybe check if the following line is in your config file.

    extension=php_mcrypt.dll

    Hope that helps.
    Matlib Australian Web Hosting
    Hosting from AUD$5 per month. Domain names from AUD$19.99.

  5. #5
    SitePoint Wizard silver trophy Jelena's Avatar
    Join Date
    Feb 2005
    Location
    Universum, 3rd Corner
    Posts
    3,001
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yes, I have that line in php.ini.
    -- Jelena --

  6. #6
    SitePoint Wizard silver trophy Jelena's Avatar
    Join Date
    Feb 2005
    Location
    Universum, 3rd Corner
    Posts
    3,001
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I kind of found solution for this. Not the best one, but unfortunately I spent way to much time trying to figure out what was the problem.

    Previously I tried to install Apache 2.2.13 and the mentioned problem with mcrypt lib was crashing apache every time, but with Apache 2.0 everything works just fine.
    -- Jelena --

  7. #7
    SitePoint Member
    Join Date
    Jan 2006
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Running windows... just use XAMPP!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •