SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    email newsletter only displays source code

    Hi, I've created an email newsletter but it only displays source code on arrival in the email client. I've done other emailings and it's always worked before. I can't for the life of me work out what I'm doing wrong now! I've taken care to use inline styles and tables, I've even tried sending it without the head etc. No joy! Please help!
    PS. I've had to take out the links in the code in order to post this message.


    Here's the code:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "[this is an a link that the forum won't let me post!].w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="[this is an a link that the forum won't let me post!] xml:lang="en" lang="en">
    <head>
    <meta content="text/HTML; charset=UTF-8" http-equiv="Content-Type" />
    <meta content="text/css" http-equiv="Content-Style-Type" />
    <meta content="en" http-equiv="Content-Language" />
    <title>Eleonora Knowland private view 1st October and the 3rd November 2009</title>
    </head>
    <body style="font-size: 10px; margin: 0; font-family: arial; background-color: #777777; color: #ffffcc; border: 0; padding: 0;">
    <style type="text/css">
    a:hover { color: #ff6600 !important; }
    </style>
    <table cellspacing="0" border="0" cellpadding="0" width="100%">
    <tr>
    <td align="center" valign="top">

    <table cellspacing="0" border="0" cellpadding="10">
    <tr>
    <td valign="top" style="color: #ffffcc; text-align: right;"><br />Email not displaying correctly? <[this is an a link that the forum won't let me post!] target="_blank" style="text-decoration: none; color: #bddfff;">View it in your browser</a></td>
    </tr>

    <tr>
    <td><img title="island" src="ekmailings/0909_LesleyCrazePV.jpg" border="0" alt="island" /></td>
    </tr>

    <tr>
    <td valign="top" style="text-align: right;">
    Copyright &copy 2009 | <[this is an a link that the forum won't let me post!] style="text-decoration: none; color: #bddfff;">Eleonora Knowland</a> | All rights reserved<br />

    <br />
    Feel free to forward this email to a friend
    </td>
    </tr>
    </table>

    </td>
    </tr>
    </table>


    </body>
    </html>

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,620
    Mentioned
    413 Post(s)
    Tagged
    7 Thread(s)
    Hey penpeg,

    I'm wondering how you are trying to send this code. I'll make a guess that you are sending it via Thunderbird. If so, you can't just paste this code into the body section. Instead, go to Insert > HTML... and a popup box appear into which you post the code.

    See it that helps. If not, describe more clearly how you are trying to use your code.

  3. #3
    SitePoint Member
    Join Date
    Sep 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I copied and pasted the code into a new message in Outlook 2000. (I don't use Thunderbird, perhaps I should!). My Outlook 2000 is configured to use Word to edit messages. Where in Outlook would I find the HTML insertion dialogue?

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,620
    Mentioned
    413 Post(s)
    Tagged
    7 Thread(s)
    As far as I know, this feature only exists in Thunderbird, but I may be wrong.

    Thunderbird is a free download, so I recommend it if you want to send HTML emails.

  5. #5
    Follow: @AlexDawsonUK silver trophybronze trophy AlexDawson's Avatar
    Join Date
    Feb 2009
    Location
    England, UK
    Posts
    8,111
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    I have Outlook 2007 and you can set HTML mode from the format ribbon section, I am guessing you can switch to HTML mode from the format menu in previous versions (based on the same logic). The following website has some information which may help you enable the mode from the options menu in earlier editions...

    http://www.emailaddressmanager.com/tips/html-email.html

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    23,620
    Mentioned
    413 Post(s)
    Tagged
    7 Thread(s)
    Quote Originally Posted by AlexDawson View Post
    I am guessing you can switch to HTML mode from the format menu in previous versions (based on the same logic).
    I checked Outlook 2003, and indeed it has the same feature. (Isn't Microsoft wonderful... ) Thanks for pointing out this feature.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •