Hello all,

I am trying to switch from sqllite3 to mysql on Ruby on Rails.

Whenever I try to install the mysql gem, i get an error:

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

I cd'd into my usr/local/bin directory and saw i have several mysql installs, and am thinking i've probably removed something along the way, and this it the problem.

Please can someone explain how to delete all instances of mysql so I can re-install?

Or - does someone know what i need to do to avoid this error?

I have installed mysql-5.1.37-osx10.5-x86 as I am running Leopard 10.5.7

ANy ideas to get me running on mysql?

Many Thanks