SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot RishikeshJha's Avatar
    Join Date
    Mar 2009
    Location
    INDIA
    Posts
    146
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem in htacess file??

    Hi,

    i am using htacess file for increasing the max upload file size. When i write this code in .htacess file, got an error "The server encountered an internal error or misconfiguration and was unable to complete your request. "

    php_value upload_max_filesize 6000M;
    php_value post_max_size 6000M;
    php_value max_execution_time 0;
    php_value max_input_time 0;

    can anyone help me why this error message is showing

    thanks in advance....

  2. #2
    SitePoint Enthusiast
    Join Date
    May 2009
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To increase the upload file size limit on your website, you need to edit PHP’s configuration settings.
    file_uploads = On
    This setting must be on. It allows running uploads through HTTP.
    Ensure this value is on the value can be On/Off or 1/0 or true/false.
    upload_max_filesize = 20M
    This value limits the size of uploaded single file. Give it value what ever your requirements.
    post_max_size = 40M
    This value limits the size of all the uploaded content. For example upload_max_filesize is for single file, if we upload 3 files simultaneously each 15mb total 45mb so it exceeds post_max_size.
    Remember post_max_size must be larger about 40% of upload_max_filesize.

    max_execution_time = 30
    Generally image uploading and manipulating with GD or Imagemagic consumes much time. So it may exceeds 30 seconds. You can modify whatever your requirements. When a script execution time exceeded by this limit the server stops the scripts or gives fatal error.

    memory_limit = 128M
    Generally image uploading and manipulation with GD or Imagemagic consumes much server memory. When it exceeds this memory the server stops executing the script, then we see empty page or no response from server or we get a fatal error.

    Completed example, to increase 10Mb
    upload_max_filesize = 10M ;
    post_max_size = 20M ;
    memory_limit = 128M

    Copy the above settings into your php.ini and put it in your web root directory.


    hope this will solve your problem

  3. #3
    Web Professional
    Join Date
    Oct 2008
    Location
    London
    Posts
    862
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by RishikeshJha View Post
    can anyone help me why this error message is showing
    No semicolons in .htaccess.

  4. #4
    SitePoint Zealot RishikeshJha's Avatar
    Join Date
    Mar 2009
    Location
    INDIA
    Posts
    146
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by decowski View Post
    No semicolons in .htaccess.
    Firstly i used it without semicolon but didn't worked. so i tried it with semicolon

  5. #5
    Web Professional
    Join Date
    Oct 2008
    Location
    London
    Posts
    862
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Then check Apache error log. It will tell you exactly what's wrong.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •