SitePoint Sponsor

User Tag List

Results 1 to 7 of 7

Thread: htaccess issues

  1. #1
    SitePoint Zealot beeXtreem's Avatar
    Join Date
    Jan 2006
    Location
    Nigeria
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    htaccess issues

    I set up a virtualhost on my system, but I seem to be having problems with the .htaccess file. I'm trying to build an app using zend frameworks, if i put the app in a folder in the localhost root directory it works fine, but when I put it in the virtualhost directory i get an error 404 - 'file not found' response.
    what could be the problem?
    JC Rocks!!

  2. #2
    SitePoint Guru
    Join Date
    Sep 2004
    Posts
    613
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It sounds like your path is off with setting up your local host. Did you modify both apahce and host.cnf (I think that's the filename) ?

  3. #3
    SitePoint Zealot beeXtreem's Avatar
    Join Date
    Jan 2006
    Location
    Nigeria
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i think I have. if i create such a directory it works. However ZF uses kind of a pretty url system which requires a htaccess file. this is where I think the fault is from. the htaccess file contains the following code:

    Code:
    # Rewrite rules for Zend Framework
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* index.php
    
    # Security: Don't allow browsing of directories
    Options -Indexes
    JC Rocks!!

  4. #4
    SitePoint Guru
    Join Date
    Sep 2004
    Posts
    613
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To be honest I'm not sure what your htaccess is doing there and I'm not familiar with the Zend Framework. However I have successfully setup 3 local servers on my laptop.

  5. #5
    SitePoint Wizard bronze trophy
    Join Date
    Jul 2008
    Posts
    5,757
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You might try
    Code:
    allowoverride all
    in your virtualhost block in httpd.conf

  6. #6
    SitePoint Zealot beeXtreem's Avatar
    Join Date
    Jan 2006
    Location
    Nigeria
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks, I'll try it
    JC Rocks!!

  7. #7
    SitePoint Zealot beeXtreem's Avatar
    Join Date
    Jan 2006
    Location
    Nigeria
    Posts
    128
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    where exactly in httpd.conf do you want me to put that line?
    JC Rocks!!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •