I'm trying to run WP o Matic (automatically creates posts from RSS feeds) and I'm running the latest version of Wordpress (2.8.2). The plugin site says it it compatible, but whenever i go to add a campaign i get

"Error 500 - Internal server error

An internal server error has occured!
Please try again later."

What's the problem?

I tried to install the SimplePie Core plugin as well, but it isn't compatible with WordPress after 2.3.3 :/ What can i do?