SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Evangelist escapedf's Avatar
    Join Date
    May 2002
    Location
    Cape Town
    Posts
    458
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    2 scripts not working - heres the URL!

    http://www.cricketsecurity.co.za/QUATTRO/try3slide.htm

    HI there people..this is my first posting..I am wondering if anyone can view the source on this URL page and see what I have done wrong!!!
    I took 2 scripts off the net..one, the image should change..the other is that scrollable text that is not working...
    any help would be great!

  2. #2
    SitePoint Evangelist pip's Avatar
    Join Date
    Jun 2001
    Location
    Cape Town, South Africa
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey... good to see another South African on here... not many of us around!

    Anyway, back to your code...

    It appears that the page is complaining about a case-sensitive issue. In your script you are referring to the SlideShow image as:

    document.images.SlideShow

    However, on the page source the name of the image is all lowercase, eg (slideshow).

    I think this is where your problem lies, although if I can give you a quick tip, try using the following in your "runslideshow()" function:

    document.images['slideshow'].style.filter="blendTrans(duration=2)"

    document.images['slideshow'].style.filter="blendTrans(duration=crossFadeDuration)"

    document.images['slideshow'].filters.blendTrans.Apply();


    and so forth... might make things a lil more understandable.

    Hope it helps...
    Last edited by pip; Jun 7, 2002 at 05:52.
    - Pip
    ---------------------------------------------------------------------------------
    Nothing takes the taste out of peanut butter quite like unrequited love.

  3. #3
    SitePoint Evangelist pip's Avatar
    Join Date
    Jun 2001
    Location
    Cape Town, South Africa
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've copied your code, and then saved the file on my drive. Then I changed the case of the name of your image from 'slideshow' to 'SlideShow', and it worked fine without altering any of the other code or script.

    That should solve your prob.

    L8er!
    - Pip
    ---------------------------------------------------------------------------------
    Nothing takes the taste out of peanut butter quite like unrequited love.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •