SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Evangelist
    Join Date
    Jun 2004
    Posts
    417
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    links not working in IE

    H ia ll,

    I have some pages on the site where some links (not all) do not work. There is no hover icon, there is simply the pointer as we kno it. The code looks fine to me. It works fine in FF.

    Any idea why this happens?

    Kind regards,
    Michel

  2. #2
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Unless you have grossly invalid markup, I doubt this is an HTML issue. It's more likely that you have done something with CSS that causes this.

    Anyway, it's impossible to say without a link to the page, or at least the relevant markup and CSS (plus any JavaScript if that's involved).

    Step 1 should, in any circumstances, be to validate your markup to make sure there's no trivial error that throws the browser off its tracks.
    Birnam wood is come to Dunsinane

  3. #3
    SitePoint Evangelist
    Join Date
    Jun 2004
    Posts
    417
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It seems that if I put an h3 inside a table, it does not work, if I put it outside the table it works. a working, stripped down example is here: http://www.thebaylodge.co.nz/problem.php

    A non workling example is here: http://www.thebaylodge.co.nz/problem2.php

    Any idea why this happens?

  4. #4
    Design Your Site Team bronze trophy Erik J's Avatar
    Join Date
    May 2007
    Location
    Countryside, Sweden
    Posts
    3,407
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It is because the header height that is restrained to 115px, giving room to the image but not the menu that is visible overflowing but covered by the next coming div "index".
    Happy ADD/ADHD with Asperger's

  5. #5
    SitePoint Evangelist
    Join Date
    Jun 2004
    Posts
    417
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Perfect! Thank you. I would not ahve founjd that myself.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •