SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE6 Browser issue.

    Hi,

    We are facing one problem only on IE6. We have used one javascript code for redirecting page after user is login. It works fine on other browser, but on IE6 after user is logged in it is showing blank page and after refresh it will show the appropriate page.

    JavaScript code:
    window.location.href='page_name.php'

    First we thought this is problem only for JavaScript but we created one test php page and added only three links by clicking on the link it will go to the site, but on first instance it is showing blank page on IE6.

    We have some other sites on same server and they all are working fine with the same code, only one domain is giving problem in IE6.

    I am using javascript only when user is logged it.

    But if I click on the "index.php" which is not javascript is a simple link still it is displaying blank page on IE6.

    Does it is related to some settings for that Domain in Apache or it is something else?

    Waiting for reply...

    Thanks in advance.

    Regards,

  2. #2
    From Italy with love silver trophybronze trophy
    guido2004's Avatar
    Join Date
    Sep 2004
    Posts
    9,495
    Mentioned
    163 Post(s)
    Tagged
    4 Thread(s)
    Does the 'blank' page contain any html code? (right click on the page and choose 'HTML')

  3. #3
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi guido2004,

    Thanks for your reply.

    When link in the test page is clicked then blank page is displayed and when right click and try to took viewsource it is not allowing me to do so.

    Regards,

  4. #4
    From Italy with love silver trophybronze trophy
    guido2004's Avatar
    Join Date
    Sep 2004
    Posts
    9,495
    Mentioned
    163 Post(s)
    Tagged
    4 Thread(s)

    I have no idea. Can you post some code here (the test php page and index.php for example)?

  5. #5
    SitePoint Wizard gRoberts's Avatar
    Join Date
    Oct 2004
    Location
    Birtley, UK
    Posts
    2,439
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    try removing .href from the javascript...


  6. #6
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi All,

    I have created the test page.

    www dot cvpartnersllc dot net slash test_cv dot php

    Please have a look on IE6 where it is showing blank page.

    Regards,

  7. #7
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To be more specific.

    Even simple link "index.php" first show blank page in IE6 and after refresh it will show the content for the same page.

    This happens only on IE6 rest of the browser works well

  8. #8
    SitePoint Enthusiast
    Join Date
    May 2009
    Posts
    65
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    why are you not redirecting through header("Locationagename.php"); this is much better then any thing else.

  9. #9
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi vaibhavcoder,

    Thanks for your reply,

    But problem is that even a simple link "index.php" is not working fine, first it shows blank page and then content of the page.

    No JavaScript redirect noting a simple HTML link.

    Regards,


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •