SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE link with background-image, problem with linebreaks

    Hello,

    I have an Internet explorer problem (versions < 8) with links with a background image.

    I am fixing some CSS bugs on a page where the design calls for lists of links which have a background-image set to repeat-x. (This background image disappears on hover.)

    When a link is longer and goes onto the next line, Internet Explorer will not display the background image at all.

    Has anyone come across this issue before?

    - I can't force it not to have a line break during the link, as the design calls for columns that are very thin.
    - If I make the link display:block, it works, but the background image continues on to the end of the line.

    Any thoughts would be greatly appreciated.

    Thanks
    Inge

  2. #2
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,722
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Does the element in question have haslayout?

    Can you give us a link to the site?
    Always looking for web design/development work.
    http://www.CodeFundamentals.com

  3. #3
    SitePoint Member
    Join Date
    Jul 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Ryan,

    Thanks for your reply.

    I'm not too sure about hasLayout, the < a > tag has value of 0 when inspected using IE developer toolbar, so I'm assuming no?

    I haven't made enough posts to be allowed add links to posts yet...
    stick it all together to make the link? sorry for inconvenience.


    ww
    w.
    whoseview.
    com/
    beta/
    categories.
    html

  4. #4
    billycundiff{float:left;} silver trophybronze trophy RyanReese's Avatar
    Join Date
    Oct 2008
    Location
    Whiteford, Maryland, United States
    Posts
    13,722
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    http://www.whoseview.com/beta/categories.html

    Ok so I'm there, but there are about 50 million links there, can you pinpoint me to where this is happening?

    And yes 0 means haslayotu is not set.
    Always looking for web design/development work.
    http://www.CodeFundamentals.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •