Anyone know why I am getting this error when trying to install ruby 1.8.6? These are the installation instructions from Simply Rails 2. The result I get is version 1.8.4. Here are the commands/results from Terminal:


make: *** [.rbconfig.time] Abort trap
BIG-MAC:ruby-1.8.6 jeff$ sudo make install
Password:
./miniruby ./instruby.rb --dest-dir="" --extout=".ext" --make="make" --mflags="" --make-flags="" --installed-list .installed.list --mantype="doc"
ruby: [BUG] Segmentation fault
ruby 1.8.6 (2007-03-13) [i686-darwin9.7.0]

make: *** [do-install-nodoc] Abort trap
BIG-MAC:ruby-1.8.6 jeff$ sudo make install-doc
gcc -g -O2 -pipe -fno-common -DRUBY_EXPORT -L. main.o -lruby-static -lpthread -ldl -lobjc -o ruby
Generating RDoc documentation
./miniruby ./runruby.rb --extout=.ext -- "./bin/rdoc" --all --ri --op ".ext/rdoc" "."
./runruby.rb:59: [BUG] Segmentation fault
ruby 1.8.6 (2007-03-13) [i686-darwin9.7.0]

make: *** [rdoc] Abort trap
BIG-MAC:ruby-1.8.6 jeff$ cd ..
BIG-MAC:build jeff$ ruby -v
ruby 1.8.4 (2005-12-24) [i686-darwin9.6.0]
BIG-MAC:build jeff$