SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot
    Join Date
    May 2009
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Vbuletin and IP move help

    Hello, i run a vbuletin forum, right now i am on a virtual dedicated

    All my ips are stored on the same root ip, i am moving one of my forums from the default IP to a separate IP. I populated the DNS and my webite shows up properly on the new IP, but my forum is comming up as a database error.

    Does anyone know what I can do to fix the problem? Or tools I can run? Or is it merely not connecting to the database yet, because of some name server or other issue?

    Help please!

  2. #2
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,692
    Mentioned
    20 Post(s)
    Tagged
    3 Thread(s)
    FTA,

    Did you copy the database (including the permissions) to the new IP? You MUST do that for it to work! If you've changed the forum configuration, you must also update the forum info in its configuration file(s), too.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator

  3. #3
    SitePoint Addict
    Join Date
    Oct 2008
    Posts
    224
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try re adding the db user once again and adding the user to the database with full privileges.
    ------------
    hzSari | HostingZoom.com
    ModVPS.com | ResellerZoom.com
    Power Speed Reliability

  4. #4
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,653
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    ^^^Please don't add full database privileges for troubleshooting. Really, really bad idea.

    I'd suspect the issue is because mysql attaches users to hosts, and you have changed the host. Modify the user so they are using the correct host.

    Probably would help to get a specific database error here as well.

  5. #5
    Certified Ethical Hacker silver trophybronze trophy dklynn's Avatar
    Join Date
    Feb 2002
    Location
    Auckland
    Posts
    14,692
    Mentioned
    20 Post(s)
    Tagged
    3 Thread(s)
    Sari,

    Sorry, I have to agree with Wyatt about the priviledges. I get lazy and do silly things like that but it's NOT good practice at all. MySQL is better than that (also cPanel) so better to use the features given to you.

    Regards,

    DK
    David K. Lynn - Data Koncepts is a long-time WebHostingBuzz (US/UK)
    Client and (unpaid) WHB Ambassador
    mod_rewrite Tutorial Article (setup, config, test & write
    mod_rewrite regex w/sample code) and Code Generator


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •