i'd searched many hours but couldn't find an official recommendation for naming PHP variables.

i think the official documents in PHP always name the variables with underscore like $var_name.

then there are many PHP source codes by others especially those from Java camp name their variables with camel style like $varName.

i find that underscore $var_name is easier to read and find, but how about you??

or am i missing the official PHP variable naming convention??