SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    May 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IIS not accessing COM references

    I have created a web service method that accesses another class For that I had to add a COM reference in my project in Visual Studio.While testing out the webservice in the development server ,everything works fine and the Boston class is accessed.
    But when i publish the webservice to IIS,I cant access the class for which I had added the COM reference.
    Do you need to add some settings or some other ocnfigurations while deploying to IIS to access COM references.

    Thanks for any help!

  2. #2
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,635
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    What is the COM reference? Is the COM object installed on the web server?

    PS: one other key question--is ASP.NET running with enough permissions to use unmanaged references?

  3. #3
    SitePoint Member
    Join Date
    May 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks,problem is solved I hadnt added the dll components in the Web Extension of IIS


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •