SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Toronto, Canada
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Images Not Displaying in Netscape 4.x/6.x

    Hi all,

    I've run into a MAJOR problem. I made a portfolio on a website (www.heavenstudios.ca/portfolio.html), which displays perfectly fine in IE, but does not appear whatsoever in NS.

    I'm using a Javascript rollover effect, as well as a side-scroller...

    I receive this error in NS 4.x:

    ___________________
    JavaScript Error:
    http://www.heavenstudios.ca/portfolio.html, line 149:
    document.images[imgName] has no properties.
    ___________________

    NS 6.x doesn't render any error messages, so I can't figure that out.

    Any help in this would be appreciated.


    Thanks,
    ...Frank
    ...Shakes


    "Whether you think you can, or you think you can't, you're right!"

  2. #2
    Grumpy Mole Man Skunk's Avatar
    Join Date
    Jan 2001
    Location
    Lawrence, Kansas
    Posts
    2,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It looks like the script you used from dynamicdrive simply isn't cross browser compatible. Either find one that is, write your own or give up on non-IE browsers.

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Toronto, Canada
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Skunk,

    Do you have any suggestions on optimizing the current script to take advantage of NS?

    If not, do you know of somewhere I can possibly find one that is cross-browser compatible? I'm having a hard time finding one, myself.


    Thanks,
    ...Frank
    ...Shakes


    "Whether you think you can, or you think you can't, you're right!"


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •