SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Evangelist
    Join Date
    Jun 2008
    Posts
    455
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Need help with Ubuntu

    Hi,

    I've just installed Ubuntu on my pc.
    I want to install xampp. I've read the instruction on the Apache Friends website on how to set it up but that has got me nowhere.

    Where should I start?

    Thanks,
    Michael

  2. #2
    Theoretical Physics Student bronze trophy Jake Arkinstall's Avatar
    Join Date
    May 2006
    Location
    Lancaster University, UK
    Posts
    7,062
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I used these instructions and had no problems:
    http://www.apachefriends.org/en/xampp-linux.html
    Jake Arkinstall
    "Sometimes you don't need to reinvent the wheel;
    Sometimes its enough to make that wheel more rounded"-Molona

  3. #3
    SitePoint Evangelist
    Join Date
    Jun 2008
    Posts
    455
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I now have xampp installed but I can't do anything with the HTDOCS folder which is in /opt/lampp/htdocs

    What do I do?

  4. #4
    SitePoint Evangelist
    Join Date
    Jun 2008
    Posts
    455
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    When I go to http://localhost i get the following error:

    Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/opt/lampp/htdocs/index.php' (include_path='.:/opt/lampp/lib/php') in Unknown on line 0
    Also, the the lampp directory seems very slim, all i have in the folder are:

    -backup
    -bin
    -cgi-bin
    -error
    -etc
    -htdocs
    -icons
    -lib
    -libexec
    -licenses
    -logs
    -modules
    -phpmyadmin
    -phpsqlliteadmin
    -sbin
    -share
    -tmp
    -var
    -lampp
    -RELEASENOTES


    There is stuff missing isn't there?

  5. #5
    masquerading Nick's Avatar
    Join Date
    Jun 2003
    Location
    East Coast
    Posts
    2,215
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had to change the permissions of my htdocs folder before I could access it. Try chmod'ing it to 777 or something.
    Nick . all that we see or seem, is but a dream within a dream
    Show someone you care, send them a virtual flower.
    Good deals on men's watches

  6. #6
    SitePoint Addict
    Join Date
    Oct 2008
    Posts
    205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    while installing did you followed the steps? Do you install it as a root user?
    check whether httpd service is stoped before starting lampp

  7. #7
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    You could instead of using a single repository for files to be included in on a web site you could try using virtual sites? Or even user (/home/username) directories http://localhost/~username

    That would be better then messing with file permissions. Thats the problem most people face when moving from Windows XP to an OS that does not give them administration access. Expect to have permission on everything.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  8. #8
    SitePoint Member
    Join Date
    Apr 2009
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    check your httpd.conf, usually in /etc or /etc/httpd....
    I am affraid, the home directory is in other directory


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •