SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2007
    Posts
    95
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    sidebar styles breaking after a search is run!

    Hello all,

    Earlier this week we launched another new web site, Crawfish.com. So I've been really busy the last few days trying to fix the bugs that have popped up. However, I can't seem to figure out why I'm having the following problem:

    If you run a search on our site, the search script works fine, and results are displayed just how we want them. However, the left sidebar completely breaks apart! For some reason, the not all of the CSS styles apply to this area any longer, and I just can't seem to figure out why.

    The header backgrounds show up, as well as some to the formatting for the paragraphs and even the link:visited, link:hover rules, etc. But the input boxes butt up against each other and the "submit" and "reset" buttons move up and over the input boxes! Also, the list under recipes inexplicably takes up way too much vertical space!! I have no idea what is causing that.

    You can see the problem here: http://www.crawfish.com/search/searc...wfish&search=1

    You can see what it should look like here: http://www.crawfish.com.

    Please help me if you can; I think it looks awful now and I have tried everything I could think of!

    If it helps, the search program I used is from Sphider (http://www.sphider.eu/)

    Thanks in advance!!!
    Independent Web Designer/Developer in Mandeville, LA USA
    1. JoeyReed.com
    2. Crawfish.com
    3. Pralines.com

  2. #2
    SitePoint Wizard bronze trophy Centauri's Avatar
    Join Date
    May 2007
    Location
    Newcastle, Australia
    Posts
    3,718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The search results page has an incomplete doctype, tripping browsers into quirks mode. For some reason, the paragraphs surrounding each label/input in the form have a height of 1% - this has no effect in standards mode, but does in quirks mode. Apart from fixing the doctype, I would also recommend removing the 1% height anyway as it is not needed.

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2007
    Posts
    95
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, Centauri! That fixed my problem right away!
    Independent Web Designer/Developer in Mandeville, LA USA
    1. JoeyReed.com
    2. Crawfish.com
    3. Pralines.com


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •