PHP Code:
asdf@sporkit.com-> script/generate model TestThing -t
      exists  app
/models/
      
exists  test/unit/
      
exists  test/fixtures/
   
identical  app/models/test_thing.rb
   identical  test
/unit/test_thing_test.rb
   identical  test
/fixtures/test_things.yml
      exists  db
/migrate
uninitialized constant Rails
::Generator::Commands::Base::ActiveRecord
  
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:493:in `const_missing_before_generators'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/lookup.rb:15:in 
`const_missing'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/commands.rb:84:in `next_migration_string'
  
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/commands.rb:361:in `migration_template'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/manifest.rb:47:in 
`send'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/manifest.rb:47:in `send_actions'
  
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/manifest.rb:46:in `each'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/manifest.rb:46:in 
`send_actions'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/manifest.rb:31:in `replay'
  
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/commands.rb:42:in `invoke!'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/rails_generator/scripts/../scripts.rb:31:in 
`run'
  /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/generate.rb:6
  /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
  
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
  script/generate:3 
Brand new to this and reading right out of the Apress book. Things seem to go fine but my migration file is never created. Where do I begin to hunt this issue down? No table was created in my db either.