SitePoint Sponsor

User Tag List

Results 1 to 17 of 17
  1. #1
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Very basic css problem

    I have been doing basic html for a while, and am trying to learn CSS. I have an idiot-simple page that calls an idiot-simple CSS. I can't give the actual source or a link, as I'm a newbie and you won't let me, but here it is as close as I can get:

    Code:
    <!DOCTYPE references XHTML 1.0 Strict>
    <!I've tried other specs w/o success>
    <head> 
    <title>This is a test</title>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
    <! a link to the CSS below goes here >
    </head>
    
    <body>
    
    <p>This is a test.</p>
    
    </body>
    </html>
    Code:
    /* 
       Test stylesheet 
    */
    
    p {
       font-size: large;
       color: red;
    }
    Both pass W3C validation. The text appears red on my Mac in Safari, but not in Firefox 3.0, nor on a PC in IE7.

    What am I missing here?

    Thanks!

  2. #2
    SitePoint Addict CWebguy's Avatar
    Join Date
    Mar 2009
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Where's your top html tag?

  3. #3
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by CWebguy View Post
    Where's your top html tag?
    I took it out because it contained what looked like a link to your forum software. It referenced w3.org/1999/xhtml. It was there, I swear, on the line after the DOCTYPE!

    I have tried this with a plain html tag, but it doesn't make any difference. In any case, I'm sure it couldn't have passed validation without it.

  4. #4
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you post a link to the page without the http:// and www. parts? I'll be able to look at it in detail that way.

  5. #5
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's pretty hard to debug code you can't see! The site is windwardconstruction associates dot com, and the files in question are named Testing dot html and style2 dot css.

    Thanks for your help!

  6. #6
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you please re-type that without any spaces and using the . instead of (dot)? I tried the links and got 404 (Not Found) errors. (If there are any dashes, please include them, like so: example-website.com )

  7. #7
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm really sorry this is so tedious... if this goes on, I'll be up to 10 posts and we won't have this problem!

    I realize the big mistake in my last post to you was "associates" which should have been "accounting". My apologies! But your site won't let me put those words together with real dots, they look too much like links.

    windwardconstructionaccounting dot com, filenames Testing dot html and style2 dot css. I had to remove all the real dots in order to get permission to post!

    Thank you for your patience.

  8. #8
    SitePoint Addict CWebguy's Avatar
    Join Date
    Mar 2009
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    see if you can add it in your user profile. I couldn't find it either.

    Cheers,

  9. #9
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by econklin4 View Post
    I'm really sorry this is so tedious... if this goes on, I'll be up to 10 posts and we won't have this problem!

    I realize the big mistake in my last post to you was "associates" which should have been "accounting". My apologies! But your site won't let me put those words together with real dots, they look too much like links.

    windwardconstructionaccounting dot com, filenames Testing dot html and style2 dot css. I had to remove all the real dots in order to get permission to post!

    Thank you for your patience.
    Ah, the boss is looking over your shoulder. That's understandable. One sec, okay?

  10. #10
    SitePoint Addict CWebguy's Avatar
    Join Date
    Mar 2009
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You stylesheet is empty

  11. #11
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, I think I found it. Look in your LINK tag (in the HEAD section) for this:

    text.css

    Replace it with this:

    text/css

    So it looks like this:

    <link href="style2.css" rel="stylesheet" type="text/css" />

    Off Topic:

    By the way, I like to write them like this - it's just a personal preference though.

    <link rel="stylesheet" type="text/css" href="screen.css" media="screen" />

  12. #12
    SitePoint Addict CWebguy's Avatar
    Join Date
    Mar 2009
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    change the text.css to text/css and it works.

    Cheers!

  13. #13
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yay, that fixed it! I knew it had to be something really lame like that! The hard things are actually easier to get right, sometimes!

    Thank you both for being so patient with me.

  14. #14
    SitePoint Addict CWebguy's Avatar
    Join Date
    Mar 2009
    Posts
    247
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hehe, no problem. Four more posts and you can actually post a link, haha

    Take care!

  15. #15
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Glad you were able to resolve that

  16. #16
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by CWebguy View Post
    Hehe, no problem. Four more posts and you can actually post a link, haha

    Take care!
    Off Topic:

    General Chat and Introductions not counting, of course.

  17. #17
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by econklin4 View Post
    Yay, that fixed it! I knew it had to be something really lame like that! The hard things are actually easier to get right, sometimes!

    Thank you both for being so patient with me.
    You're welcome.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •