SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Enthusiast
    Join Date
    Jun 2008
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help: WP blog showing erro 404 - Not found

    This is the message I am getting on content pages (only the contnet pages) and not the home page or the main category pages. In the url of the pages between the date and the title of the post (which makes up rest of the url) I am getting the following %EF%BF%BDy%

    Example:

    http://www.site.com/2009/03/%EF%BF%BDy%/title-title-title/


    How can I solve this problem. By the way, I have not changed any code whatsoever other than create a new post this morning like I usually do everyday.

  2. #2
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you have FTP you can log on and look if your content is in the right directory so in your www/2009/03/efefefefef/title.html
    and not somewhere else and make sure the title.html is correctly spelled


    Good luck

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2008
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thats not it. All my content pages i.e. the posts are showing that error image on Firefox while on IE, the pages do not load at all. There isn't however any problem with the home and the category pages.

    Lets take the sitepoint blog as an example about the post on why you need a powerful elevator pitch.

    http://www.sitepoint.com/blogs/2009/03/24/%EF%BF%BDy%why-you-need-a-powerful-elevator-pitch/

    The bold lettering indicates the error I am getting so the urls aren't loading.

    I would have thought there would plenty of WP experts here who would know how to resolve this problem pretty easily.

    Any help greatly appreciated.

    Thanks

  4. #4
    SitePoint Wizard bronze trophy Tailslide's Avatar
    Join Date
    Feb 2006
    Location
    Bedford, UK
    Posts
    1,687
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi
    I'm really no expert but until someone comes along..

    1. Does it happen if you use a different permalink structure? (if not check your chosen permalink structure is correct)
    2. Check that the encoding that your webserver is using is the same as on the WP header (e.g. UTF-8 )
    3. Are you getting the weird string after the post title too? If so it may be something to do with using smart quotes ( ” ) instead of normal quotes ( " ) around the post title?
    Little Blue Plane Web Design
    Blood, Sweat & Rust - A Land Rover restoration project

  5. #5
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are your URL's dynamic or static?

  6. #6
    #titanic {float:none} silver trophy
    molona's Avatar
    Join Date
    Feb 2005
    Location
    from Madrid to Heaven
    Posts
    8,271
    Mentioned
    252 Post(s)
    Tagged
    1 Thread(s)
    It looks like you have a mod_rewrite (if you are using apache) or something similar that create user friendly links but the regular expression is not working properly. This is a feature that WP offers through their admin panel.

    Those symbols that you are seeing there are for the date, which are not showing properly. I don't know what hacks and changes you've done to your WP installation, but I would suggest that while you sort it out you change the link structure to something else (In WP admin, Choose Options, then permanent link) and see what happens.

  7. #7
    SitePoint Enthusiast
    Join Date
    Jun 2008
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by molona View Post
    It looks like you have a mod_rewrite (if you are using apache) or something similar that create user friendly links but the regular expression is not working properly. This is a feature that WP offers through their admin panel.

    Those symbols that you are seeing there are for the date, which are not showing properly. I don't know what hacks and changes you've done to your WP installation, but I would suggest that while you sort it out you change the link structure to something else (In WP admin, Choose Options, then permanent link) and see what happens.
    Will this change the url structure because the blog is 3 years old and Idon't have the site reindexed and lose the current traffic I am getting.

  8. #8
    SitePoint Enthusiast
    Join Date
    Jun 2008
    Posts
    91
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by molona View Post
    It looks like you have a mod_rewrite (if you are using apache) or something similar that create user friendly links but the regular expression is not working properly. This is a feature that WP offers through their admin panel.

    Those symbols that you are seeing there are for the date, which are not showing properly. I don't know what hacks and changes you've done to your WP installation, but I would suggest that while you sort it out you change the link structure to something else (In WP admin, Choose Options, then permanent link) and see what happens.

    Thanks. This worked. Really appreciate the help. I don't know how that got chnaged because I did not touch the code at all.

  9. #9
    #titanic {float:none} silver trophy
    molona's Avatar
    Join Date
    Feb 2005
    Location
    from Madrid to Heaven
    Posts
    8,271
    Mentioned
    252 Post(s)
    Tagged
    1 Thread(s)
    Glad that it worked and I could help. Don't worry about it. Sometimes this things happen and there are various reasons that may affect how the software works. It will be imposible to know the reason.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •