SitePoint Sponsor

User Tag List

Results 1 to 9 of 9
  1. #1
    SitePoint Wizard Jun Valasek's Avatar
    Join Date
    Dec 2007
    Posts
    1,292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    www and http question

    All of my 3 new websites are not generating www.. Even if I type http://www.yourdomain.com, all are changing to http://yourdomain.com when page is open...

    Is there any problem with this? I am asking because I am having irrelevant ads on adsense in all 3 sites thogh these sites are optimized well..

    Thanks

  2. #2
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it sounds like a 301 redirect. This can be triggered from an mod_rewrite rule in Apache, or can possibly be the script on your website doing the forwarding. I'd recommend scanning over your .htaccess file looking for something having to do with mod_rewrite. If you find anything, comment is out, and see if it still forwards you.
    Aquarius Storage - Stop Searching, Start Hosting
    Fast & Reliable Shared/Reseller/VPS Hosting
    http://www.aquariusstorage.com

  3. #3
    SitePoint Wizard Jun Valasek's Avatar
    Join Date
    Dec 2007
    Posts
    1,292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by AquariusRyan View Post
    it sounds like a 301 redirect. This can be triggered from an mod_rewrite rule in Apache, or can possibly be the script on your website doing the forwarding. I'd recommend scanning over your .htaccess file looking for something having to do with mod_rewrite. If you find anything, comment is out, and see if it still forwards you.
    All 3 uses wordpress script...

    I checked one of them and set htt_access permission to 777, still the same problem..

  4. #4
    ✯✯✯ silver trophybronze trophy php_daemon's Avatar
    Join Date
    Mar 2006
    Posts
    5,284
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Add the www to the url in your wordpress settings (under General).
    Saul

  5. #5
    SitePoint Wizard Jun Valasek's Avatar
    Join Date
    Dec 2007
    Posts
    1,292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by php_daemon View Post
    Add the www to the url in your wordpress settings (under General).
    I think this happened because I installed the script through fantastico... which I am not used to do... I always install wp manually and never experienced this problem..

    Owww... how come I missed this simple instruction.. ha ha.. it's okay now.. thanks a lot...

  6. #6
    SitePoint Zealot Cassidy's Avatar
    Join Date
    Mar 2009
    Location
    Texas
    Posts
    103
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You need to be concerned if your site will display BOTH http://www.mysite.com AND http://mysite.com. It's ok if the redirect happens, but if both display the search engines will see that there are 2 different sites with identical content.
    Cassidy
    Income Mobility Make Your Income Upwardly Mobile
    WEB HOST with unlimited domains, Bandwidth, Disk Space, MYSQL
    $25 first year limited time offer Jiffy Hosting

  7. #7
    SitePoint Wizard Jun Valasek's Avatar
    Join Date
    Dec 2007
    Posts
    1,292
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Cassidy View Post
    You need to be concerned if your site will display BOTH http://www.mysite.com AND http://mysite.com. It's ok if the redirect happens, but if both display the search engines will see that there are 2 different sites with identical content.
    Yeah I understand... I just wonder why I cannot open www..

    Anyway my ads are targeted now..

  8. #8
    SitePoint Wizard silver trophy ldcdc's Avatar
    Join Date
    May 2004
    Location
    Ploiesti
    Posts
    4,474
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's ok if the redirect happens, but if both display the search engines will see that there are 2 different sites with identical content.
    The risk is there, but search engines should be pretty well aware of this situation occurring on a very large scale, and not jump to conclusions. Anyway, there's no harm in not having www work. I've always preferred that, and never had any issues.
    HostPeek.com - budget hosts, compared
    CouponsNexus.com - web hosting coupons

    Ultra Cheap Hosts | Web Hosting Reviews Forums

  9. #9
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by php_daemon View Post
    Add the www to the url in your wordpress settings (under General).
    This will work




Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •