SitePoint Sponsor

User Tag List

Results 1 to 15 of 15
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    3 state button not working - hopefully not as simple as you'd think...

    Hi Guys,

    I'm trying to get my website 'apps-limited uk' to have working 3 state mouse buttons which are selectable by tab, accesskeys, etc...

    For some reason the 3rd state shows fine in Safari (3.22), not at all in IE(All - IE Tester) or FF(3.0.5), and god only knows what's happening in Opera (9.63)

    The javascript is here at the root, and is called rollover

    Can anyone help?

    Thanks in advance


    Jim

    PS I'd post links but I can't due to anti-spam and me being new and all...

  2. #2
    We're from teh basements.
    Join Date
    Apr 2007
    Posts
    1,205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I got a 404 at http://www.apps-limited.uk/

    I can tell you there are different ways of referencing mouse buttons among browsers. Check out https://developer.mozilla.org/en/ and http://msdn.microsoft.com/en-us/library/aa155110.aspx for some browser-specific information on event handling.

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it's a normal united kingdom address...I can't post the real suffix until I've replied to 10 threads - it's like some bad joke chain letter!

  4. #4
    We're from teh basements.
    Join Date
    Apr 2007
    Posts
    1,205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jmsherry View Post
    it's a normal united kingdom address...I can't post the real suffix until I've replied to 10 threads - it's like some bad joke chain letter!
    Was the URL I posted correct?

    Just make 10 nonsense posts in the General Chat forum, and you will be able to post links.

  5. #5
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,526
    Mentioned
    83 Post(s)
    Tagged
    3 Thread(s)
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  6. #6
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks pmw57...Yes, just like that!

  7. #7
    SitePoint Guru
    Join Date
    Sep 2006
    Posts
    731
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by jmsherry View Post

    For some reason the 3rd state shows fine in Safari (3.22), not at all in IE(All - IE Tester) or FF(3.0.5), and god only knows what's happening in Opera (9.63)
    The focus event follows click, so the click image is overwritten. It's better to apply all event handlers to the link, and assign the same handler to mouseover and focus. The same for mouseout and blur.
    No need to re-invent the wheel: SmartRoll
    Tab-indentation is a crime against humanity.

  8. #8
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    blah

  9. #9
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ignore

  10. #10
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    trying to get to be able to post urls

  11. #11
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    this is dull

  12. #12
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    oh my god

  13. #13
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    that's the funky...

  14. #14
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hallelujah!

  15. #15
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Location
    London
    Posts
    45
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi guys,

    Sorry about the posts above, I just got bored of not being able to post URLs...

    I still don't understand this fully. The code is good as it comes from Lynda.com, and works in chrome & safari, but not in FF or IE...It goes crazy in Opera...

    It always seems to 'lag', could it be that the DOM command that I put in

    Code:
    	if (document.images[i].parentNode.parentNode.parentNode.parentNode.id == "nav-menu"){
    is taking too long to execute?

    The help above is also appreciated; wouldn't the links come out blurred until focussed on by mouse or tab order though?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •