SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Got blank page when running php

    Hello:

    I have display_errors = on. I also try to enable log_errors, rack_error etc, but I still get blank page.

    Here is my php.ini. Thanks
    Attached Files Attached Files

  2. #2
    ✯✯✯ silver trophybronze trophy php_daemon's Avatar
    Join Date
    Mar 2006
    Posts
    5,284
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Do you get this when running every single script? Even if it's just a 'hello world' script, or is that only happening with a certain type of script that, for example, uses database?

    Just a stab in the dark (the attachement is pending approval yet anyway), but have you got mysql extension enabled. It comes disabled by default, and as far as I remember has a similar 'blank page' effect.

  3. #3
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question

    Hello:

    Thanks for the response. I could run single scirpt: "hello world", but I could not run other php code. Here is the code I tried to run and return blank page:

    Thank you very much!
    Attached Files Attached Files

  4. #4
    Twitter: @AnthonySterling silver trophy AnthonySterling's Avatar
    Join Date
    Apr 2008
    Location
    North-East, UK.
    Posts
    6,111
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Post the code, your attachments are not approved.
    @AnthonySterling: I'm a PHP developer, a consultant for oopnorth.com and the organiser of @phpne, a PHP User Group covering the North-East of England.

  5. #5
    SitePoint Enthusiast
    Join Date
    Jan 2005
    Location
    New Jersey, USA
    Posts
    71
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your problem is most likely in Test_menus.php which is included just below the <body>. Can you post the code for that page?

  6. #6
    SitePoint Member
    Join Date
    Mar 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think you may check whethrt the PHP version is matched


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •