SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2008
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help a PHP newb ... php.ini

    How do I save this file in Mac OS X? I'm using Text Wrangler to open the file. When I try and save it, I get an error saying I don't have permission.

    I'm a bit of newb to both Mac and PHP, so if someone can help out I'd be most appreciative.

    Thx.

  2. #2
    SitePoint Guru
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    971
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There is a video tutorial that helps set up php in mac http://www.lynda.com/home/DisplayCourse.aspx?lpk2=435

    The video in that link may not be free, but there is some clip which free. If the needed video is not free you can get the title then search and download from some other source

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2008
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your help, but really I'd prefer not to sign up to a new site and then sit through a whole video tutorial just to find out how to enable writing permission for that system directory, which is probably a 1 second task.

    Can someone that knows just tell me? Please? I'm sure it's a simple thing if you know how...

    Thanks.

  4. #4
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    I do not have a Mac but I assume php.ini is in a folder you do not have permission to write to, so you must open it using root permissions. Probably sudo though the command line.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  5. #5
    SitePoint Zealot
    Join Date
    Dec 2008
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, the problem was that I couldn't see the folder. I found a terminal command last night that made them all visible, so it's no problem, fixed.

    Cheers.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •