SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast weich1213's Avatar
    Join Date
    Nov 2008
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question probably a stupid question but...

    i'm trying to create a site using include files. I don't know css that well but I'm trying to get by. everything on the following page looked ok until I added the logos graphic to the center of the page, now the bottom include file is not displaying correctly as you can see on the page. The page address is:

    http://www.eclipsedesignca.com/logo.php

    Thanks.

  2. #2
    Follow: @AlexDawsonUK silver trophybronze trophy AlexDawson's Avatar
    Join Date
    Feb 2009
    Location
    England, UK
    Posts
    8,111
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Part of the problem is you have declared a doctype in every include file... this is wrong. Includes embed whatever content was inside the file into the existing document, what this means is that all the includes are combined and embedded directly into the single file, therefore if you have a doctype in every include, it will put doctypes in every region an include was defined. Look at your source code in your browser... you will see what is happening is you are literally repeating the same code over and over. You should put your website through the W3C validator and clean up the source code... that should resolve many of the issues you are getting.

  3. #3
    SitePoint Enthusiast weich1213's Avatar
    Join Date
    Nov 2008
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks

  4. #4
    SitePoint Enthusiast weich1213's Avatar
    Join Date
    Nov 2008
    Posts
    89
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I took out the doc types in the include files but it still does the same thing since I added the "logos" graphic. I guess I'm screwed.

  5. #5
    Follow: @AlexDawsonUK silver trophybronze trophy AlexDawson's Avatar
    Join Date
    Feb 2009
    Location
    England, UK
    Posts
    8,111
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Well I did tell you to validate your code but you have not done so, therefore I am not suprised.

  6. #6
    SitePoint Enthusiast
    Join Date
    Jan 2009
    Location
    Canada
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    When you are including files, your include files shouldn't be complete web pages, only parts of them. You are including entire files, including body tags. My first 10 seconds of looking showed multiple <body> tags. If you would validate your code, you are going to get hundreds of errors probably.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •