I am fairly new to RoR and am following 'Simply Rails 2'.

I am having an issue with the rake command:

$ rake db:migrate

When executing this command, the following error displays:

Rails requires RubyGems >= 1.3.1 (you have 1.0.1). Please `gem update --system` and try again.

I have updated my RubyGems and checked the version which indicates that I do have version 1.3.1

I have checked the internet for help with this but can't seem to find a solution to the problem..

Any help with this would be appreciated