SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2009
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Red face Wordpress Needs to be Reinstalled? Not there?

    So I visited my site today only to have it redirect to the install page /wp-admin/install.php where I fear someone else can hijack my site.

    The files are still on the server (and I hope the DB is intact).

    What do I do??? Do I reinstall or will that overwrite something?
    Same name and email address?

    Thanks

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    16,439
    Mentioned
    160 Post(s)
    Tagged
    1 Thread(s)
    Did you just install an upgraded version and forget to go to "upgrade.php" to update the database?

  3. #3
    SitePoint Enthusiast
    Join Date
    Jan 2009
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No, I have not updated any WP files or the database

  4. #4
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    16,439
    Mentioned
    160 Post(s)
    Tagged
    1 Thread(s)
    I just went to the "store" and "seo" blogs in your sig links. Both loaded OK and when I went to the login screens, they loaded OK too. Is the redirect happening when you try to log in? Or are you having problems with a different blog? Are any messages appearing on the screen that may help me track down what is involved with this?

  5. #5
    SitePoint Enthusiast
    Join Date
    Jan 2009
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry this has been solved. For others trying to diagnose the problem:

    Host moved the location of the database so wp-options was not calling the right location. All other indications were that things were set up so this is hard to identify without looking in MyPHPAdmin or whatever you use to look at your SQL DB.

    Need to work with host to fix as they have to indicate the new location.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •