SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru
    Join Date
    Jul 2004
    Location
    Netherlands
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Invalid gems install rails ???

    I keep getting invalid gem when i try to install rails??

    $sudo gem install rails -v=2.1.2

    With ActivRecord, ActiveSupport they all give problems when I download the gems with lynx and install them with:

    $sudo gem install --local activerecord-2.1.2.gem

    It does install but it kinda sucks does anybody know a solution. I just wanna try out redmine, but it seems rails app tend to break easy even with a minor update in framework
    Go visit my site :-D you know you want to ;-)
    www.mech7.net

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,053
    Mentioned
    187 Post(s)
    Tagged
    2 Thread(s)
    Could the correct CL syntax be
    Code:
    $sudo gem install rails -v 2.1.2
    without the equal sign?
    Or maybe try without the version if you don't mind using 2.2

  3. #3
    SitePoint Guru
    Join Date
    Jul 2004
    Location
    Netherlands
    Posts
    672
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Mittineague View Post
    Could the correct CL syntax be
    Code:
    $sudo gem install rails -v 2.1.2
    without the equal sign?
    Or maybe try without the version if you don't mind usin 2.2
    Redmine does not support higher then 2.1.2... when I delete the files and use:

    $sudo gem install rails -v=2.1.2 --include-dependencies it seems to work, maybe installing the first 2 manual also helped am not sure
    Go visit my site :-D you know you want to ;-)
    www.mech7.net

  4. #4
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,053
    Mentioned
    187 Post(s)
    Tagged
    2 Thread(s)
    Ah, I was thinking the invalid gem error was about the rails gem (hence my thought that it might be looking for invalid =2.1.2 instead of valid 2.1.2). But it must have been that it couldn't use another gem with a version other than what it depended on. i.e. one of the dependencies was the wrong version and therefore invalid.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •