SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict khuramyz's Avatar
    Join Date
    Oct 2005
    Location
    Manchester, UK
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile Upgrading my server to Magento

    Hi Guys

    Hope you are doing well.
    I have a dedicated linux server which runs PHP 5.1.6.
    However, I cannot run magento separately as it required PHP 5.2.0 at least.
    The work around is to use PHP-CGI.
    I am just starting to learn magento and cannot consider myself upto such kind of decisions.
    I talked to my hosting people about upgrading to php 5.2.0 and they say that hosting panel might not work as intended which stopped me.
    Can anyone please suggest as to what route I should take.
    Is running magento under PHP-CGI any kind of hinderence in performance, personalization and development. What do you suggest about upgrading my hosting. I am running about 30 client domains and I am afraid to take any step without an expert advice.

    Kind Regards,
    Khuram
    Khuram Javaid
    PHP Developer and Entrepreneur
    http://www.phprad.com/

  2. #2
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,551
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    I'd consult with the vendor of the control panel directly and check compatibility. Which control panel are you using?

  3. #3
    SitePoint Addict khuramyz's Avatar
    Join Date
    Oct 2005
    Location
    Manchester, UK
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am using Parallel Plesk control panel.
    Khuram Javaid
    PHP Developer and Entrepreneur
    http://www.phprad.com/

  4. #4
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,551
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    I've had a server with plesk upgraded to php 5.2.6 so it is possible. If the hosting company know what they're doing with plesk there shouldn't be a problem.

  5. #5
    SitePoint Addict khuramyz's Avatar
    Join Date
    Oct 2005
    Location
    Manchester, UK
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi EastCoast,

    It was actually the hosting company's stand that they were unsure of Plesk working on advance PHP settings. I am not sure if they are upto the task.
    Khuram Javaid
    PHP Developer and Entrepreneur
    http://www.phprad.com/


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •