SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2007
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Really dopey ... but cant remember how to set up include_path in php.ini

    Hi,

    completely dopey question ... but I can't for the life of me remember how to do this ...

    Got a php/mysql/apache set up on local pc under a folder called AServer. Got a subfolder under AServer called Sites which has subfolders holding various stuff for multiple sites ...

    http.conf has document root set to "C:/AServer/Sites"

    Problem is, I deleted the 'latest' version of my php.ini and don't have a backup ... working my way thru the associated problems (missing extensions etc) but got stuck here ...

    Got a folder c:\AServer\Sites\includes which, strangely, holds all the 'common' included files ...

    Got another folder called c:\AAerver\Sites\musicinc which holds other files to be included in various places...

    Question is, what do I need to put in my include_path = statement in the php.ini to make sure that both the above folders are searched (includes first, musinc second and lastly, the current folder the script is running in) whenever php finds an 'include' line ???



    hope someone can help....

  2. #2
    SitePoint Wizard bronze trophy
    Join Date
    Jul 2008
    Posts
    5,757
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    c:\AServer\Sites\includes;c:\AAerver\Sites\musicinc;.

    http://www.php.net/manual/en/ini.cor...i.include-path

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2007
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thank you ... it was the colns and semi colons and full stop that confused me!!!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •