SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict s|k's Avatar
    Join Date
    Apr 2002
    Location
    Hilo, Hawai'i
    Posts
    266
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry i can't mail()!!!windows&apache !=mail

    okay, can I get some suggestions please, I'm trying to use mail() in a script but my system configuration is all wrong. I've have 3 different books on php and all of them are no help. I'm writing scripts, just to learn php atm, on my computer and I test them using http://localhost/ I use apache 1.3, PHP 4.1.2 and windows xp

    My books say to get IIS because it has a built in mail server that will let me use localhost, but I dont want IIS i'm happy with apache. My ISP wont let me use their SMTP, online documentation is null, I even googled it, and google failed me( I probably am not doing the search right). Can I someone point in me in the right direction please? Thanks.

  2. #2
    SitePoint Member
    Join Date
    May 2002
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    right,

    open php.ini (ussally in the Windows directory).

    Go down to the mail server bit where it will ask about smtp address.

    Most SMTP servers dont require auth so just use your ISPs.

    I use smtp.netdirect-online.co.uk.

    Hope this helps.

    .icecube

  3. #3
    SitePoint Addict s|k's Avatar
    Join Date
    Apr 2002
    Location
    Hilo, Hawai'i
    Posts
    266
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I cant use my ISP, already tried :/

    thanx anyways


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •