SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Guru
    Join Date
    Dec 2008
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Object doesn't support this property

    my page was working fine but bu mistake i deletd something and now i am getting error and not able to trace it. i tried all possible debug
    culd anyone tell me how to trace the error
    the error at present i am getting is
    Microsoft JScript runtime error: Object doesn't support this property or method
    my page has a combination of stylesheet, asp.net contols and javascript

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    Sadly that error message from Internet Explorer means very little.

    If you have Firefox or Google Chrome. they can both provide you with an amazing amount of detail about what the problem is.

    With Firefox you would go to the Tools menu and choose Error Console

    With Chrome you would click the icon for the current page (at top right), select Developer and then Javascript console
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    SitePoint Guru
    Join Date
    Dec 2008
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i was trying the same
    in google chrome it doesnt give me any such error
    but in IE is says expected ) in line 411
    in debugging mode line 411 contains stylesheet
    which is already checked. is there any means to find out where the error is
    a wrking page giving such a mistakes is really not worth

  4. #4
    SitePoint Guru
    Join Date
    Dec 2008
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi paul
    just can say thanks
    as u r timely help / guidance was what i needed.
    i found one of the errors .it was by mistake that a character was entered with a object name.

    no words to praise u r help/ guidance
    will need more assistance frm u as u r really a master in scripting i feel

    in chrome the bgcolor of div(sub1) is not displayed by the actual color it becomes white whereas in IE and firfox its displayed.

    the prblm of the div(sub1) not getting dispalyed in other browser too got solved. now i need to check for its wrking.

    just a small word thanks


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •