SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Oct 2008
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Greybox Doesn't Work in IE 7

    I am having a really tough time getting greybox modal windows to work in IE. It seems to work just fine in every other browser, but IE7 on Windows just chokes. I am getting a consistent error messages when I check the JavaScript console in Firefox, telling me that GB_showImageSet is not defined. I am completely stumped on this one. Any insight would be greatly appreciated!

    The crazy thing is that the example page doesn't even work in IE, yet others have said (including the developer) that it is cross-browser...I'd really like to use this script as I have everything all put in its place, etc....

    This silly forum won't let me post any links (sort of defeating the whole purpose, no?)....so if you have any experience with greybox or anything similar PLEASE PM me if you have a moment to take a look!

    Thanks!

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    The examples from http://orangoo.com/labs/GreyBox/ seems to work perfectly fine in IE7, IE6, Google Chrome and Firefox for me with no errors or warnngs.

    You're welcome to post your own test page. If you're not allowed to post an actual link, you can at least do the following, as an example:

    orangoo dot com slash labs slash GreyBox
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    SitePoint Member
    Join Date
    Oct 2008
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks so much for testing that..I am wondering if the security settings on my IE browser at work that are administrator controlled, like the phishing filter, caused problems - that is where it seemed to hang. I am working on installing Parallels so I can test at home on Windows/IE...

    Under the assumption that I will be able to get it to work in IE, I will move forward. My problem now is that I can't get it to use multiple image sets. I've made a few small mods to the script that work great, but simple adding another var image_set2 breaks the whole script. I know I am probably breaking a basic JavaSCript syntax rule here, but I am still learning

    Click "Firetap" and "Futuregarden" - those work great...trying to add another image_set onto "NV Clothing". I have the code commented out right now...

    The page is here:
    adamfialkov DOT COM / staging

  4. #4
    SitePoint Wizard webcosmo's Avatar
    Join Date
    Oct 2007
    Location
    Boston, MA
    Posts
    1,480
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    You probably gonna digg through their tutorials. I am using greybox, works perfectly on all major browsers I can tell you that

  5. #5
    SitePoint Member
    Join Date
    Oct 2008
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've been through all of their files - it explains how to do "image sets", but doesn't talk about multiple image sets...I know it is just an issue with using two var statements, but I think I need to review some more basic JavaScript tutorials as well. Thanks for your help - if anyone has experience doing this, please post back!

    Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •