SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Thread: Problem with IE

  1. #1
    SitePoint Enthusiast kangkenyot's Avatar
    Join Date
    Apr 2008
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with IE

    One of my page is not works well on Internet Explorer while perfectly works on other browsers such as Firefox, Opera, Safari, Google chrome.

    The page what i mention above is Web Diagnostic For WebMaster

    The 1st problem is come from Google Analytic Java Script.
    IE said "Error: '_gat' is undefined
    complete script for GA is
    var pageTracker = _gat._getTracker("UA-958897-7");

    The 2nd problem is when i click on the botton to proceed with web analysis.
    IE bring back to the blank form without any error message.
    I suspect it something like undefined runtime error

    Please advise what i must do for Internet Explorer

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,705
    Mentioned
    102 Post(s)
    Tagged
    4 Thread(s)
    Your page has some serious validation errors on it that are going to cause IE big trouble.
    Run your page through your own validation routine and you'll see what I mean.

    The html validation link from your page doesn't work either. Here's one that does work.
    http://validator.w3.org/check?uri=ht....com/webcheck/
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •