Hi,

I have mysql 4.1.22 compiled on RHEL 4 and running fine. Over the time the threads / pids of mysql keep on increasing.
For eg :
ps -ef |grep mysql |wc -l
63
ps -ef |grep mysql |wc -l
101

The system is Intel Dual Core, RHEL4, 300 GB SATA HDD with 16GB RAM. Also I have observed that I cannot login into mysql shell when the process count goes higher beyond 100 meaning that it takes lots of time to enter into the mysql> shell

I am using the my-innodb-heavy-4G.cnf as my.cnf with couple of modifications like
max_connections=1000
skip-name-resolve
innodb_file_per_table
innodb_flush_method=O_DIRECT
lower_case_table_names=1
expire_logs_days = 10
net_read_timeout=60
net_write_timeout=120
max_connect_errors = 100
innodb_locks_unsafe_for_binlog=1
innodb_flush_log_at_trx_commit=2
innodb_lock_wait_timeout=300
myisam_repair_threads = 10
innodb_file_io_threads = 20
innodb_thread_concurrency = 16
innodb_table_locks = 0
wait_timeout = 480

Rest of the settings remain same.

The configure command used for compiling mysql is
CFLAGS="-static -O3 -march=nocona -funroll-loops" \
CXX=gcc CXXFLAGS="-static -O3 -march=nocona -pipe -mmmx -msse -msse2 -mfpmath=sse,387 -funroll-loops -fno-exceptions -fno-rtti -fomit-frame-pointer -felide-constructors -mtune=nocona" \
./configure \
--prefix=/usr/local/mysql \
--with-mysqld-user=mysql \
--libexecdir=/usr/sbin \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--with-client-ldflags=-all-static \
--with-mysqld-ldflags=-all-static \
--with-thread-safe-client \
--with-unix-socket-path=/tmp/mysql.sock \
--localstatedir=/usr/local/mysql \
--enable-assembler \
--disable-shared \
--without-readline \
--without-debug \
--without-docs \
--without-bench

and then make, make install and strip /usr/sbin/mysqld

What am I doing wrong and why the process count is increasing over the time ?

Regards
Shann