SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Feb 2001
    Posts
    58
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    dropdown menu is slow

    http://www.ctmremediation.com

    the upper nav is reacting very very slow to mouseover.
    any ideas?

    thanks for the help.

  2. #2
    What? Maelstrom's Avatar
    Join Date
    Oct 2001
    Location
    Whistler BC originally from Guelph Ontario
    Posts
    2,175
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 - Where did you get the code for the drop downs. It is likely in there. Either poor coding or something of the like

    2 - I don't think number 1 is the problem. You whole site loads very poorly. It is jumpy and isn't smooth. It may have something to do with your cacheing turned off...try turning it on and just seeing if that helps any?
    Maelstrom Personal - Apparition Visions
    Development - PhP || Mysql || Zend || Devshed
    Unix - FreeBSD || FreeBsdForums || Man Pages
    They made me a sitepoint Mentor - Feel free to PM me or Email me and I will see if I can help.

  3. #3
    SitePoint Wizard Aes's Avatar
    Join Date
    Jun 2001
    Location
    Oklahoma
    Posts
    3,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think it has to do with Maelstrom's number one. I do not know client-side scripting overly well, however, I do not see how poor coding in the rest of the site design would contribute to the slow operation of the dynamic drop-down menus. If you know client-side coding then go through it and find any bad or unnecesary coding; otherwise post a thread in the client-side forums and I'm sure you'll receive some help! Good luck.

    -Colin
    Colin Anderson
    Ambition is a poor excuse for those without
    sense enough to be lazy.

  4. #4
    pg for mild peril cow's Avatar
    Join Date
    Mar 2000
    Location
    nevada, usa
    Posts
    636
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmmm, at first glance it looks like it could be something with the drop down menu coding. but every other page on that site has the same slow loading problem.

    try increasing the size of your background image from the 2x2 to 6x6, using the same pattern. it's likely that your problem lies in the combination of no-cache and having the browser render the bg image a thousand times.
    "There's no justice like angry mob justice!" --Seymour Skinner

  5. #5
    What? Maelstrom's Avatar
    Join Date
    Oct 2001
    Location
    Whistler BC originally from Guelph Ontario
    Posts
    2,175
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I did forget to mention that I loaded it in Opera (I assumed it wouldn't work simply because opera has no good support for dhtml . With Opera everything is fast and smooth. You menus come up quickly, with no content. This tell me that it is probably lengthy code. But it could depend on how you are populating the menus.
    Maelstrom Personal - Apparition Visions
    Development - PhP || Mysql || Zend || Devshed
    Unix - FreeBSD || FreeBsdForums || Man Pages
    They made me a sitepoint Mentor - Feel free to PM me or Email me and I will see if I can help.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •