SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    javascript:history.go(-1)

    This is STILL driving me absolutely insane. I am using this code within flash to go to previous page from browsers history. It works fine on my mac, but testing in Windows IE7 it only works once.

    http://www.bloxdesigns.com/jewelry/n...em2/index.html (then I click on picture link on bottom and on next page hit "back" it works and then I hit "back" again and it just seems to try to reload the current page even though my browser's back button works.)

    Just for fun I took the code out of flash and placed directly on the page ... then it worked. I still might have to do this (which will mean I will have to redesign the site.) I have also tried history.back(), placing the AS directly on the button, putting it on both the onRelease and onPress handlers and calling it as a function that I place in my HTML. I have been stuck for days ... any help is so appreciated!!!!!! My FLA is at http://www.bloxdesigns.com/flash/item01.fla

  2. #2
    SitePoint Addict
    Join Date
    Jul 2005
    Location
    USA
    Posts
    291
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    what url are you trying to load? if you want to use the back/forward buttons, you generally load a url into an iframe which talks to some javascript in the parent frame. it looks like a url is being loaded into the parent every time (which is why the page is reloading.)

    take a look at swfaddress for some samples on how to accomplish this


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •