SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Tokyo
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    iframe positioning in netscape and opera

    I created an iframe for displaying photos and have it centered on the page. It's fine in IE, however in Netscape 6 and Opera 6 it won't center (it stays on the left). Here is the code snippet:

    Code:
    <td height="210" valign="top">
     <p><iframe src="randomimages2.htm" name="randomimage"
    width="300" height="200" border="0" framespacing="0" 
    frameborder="0" marginwidth="0" marginheight="0" 
    scrolling="no" align="center" hspace="0" vspace="0" 
    class="unnamed2">Text about old browsers 
    here.</iframe></p>
              </td>
    I'm sure there's a tag I need to add to get the thing properly aligned in NN and Opera, but can't seem to find what it is. Please help.

  2. #2
    SitePoint Wizard iTec's Avatar
    Join Date
    May 2001
    Location
    Sydney, Australia
    Posts
    2,243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    is there a link were we can see the full source? the code youve given us doesnt help at all.

  3. #3
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Tokyo
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    link

    yes, the page is here:

    http://www.easterwood.org/index.htm

    (just my humble little personal site).

    thanks!

  4. #4
    SitePoint Wizard iTec's Avatar
    Join Date
    May 2001
    Location
    Sydney, Australia
    Posts
    2,243
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    answer

    Code:
              <TD vAlign=top height=210 align="center"> 
                <P><IFRAME class=unnamed2 border=0 name=randomimage align=center marginWidth=0 frameSpacing=0 marginHeight=0 src="randomimages2.htm" frameBorder=0 width=300 scrolling=no height=200 id="randomimage">The 
                  above frame contains images. However, if you're still using Netscape 
                  3 or 4 as your browser, you won't be able to see it. I would recommend 
                  you upgrade your browser (for free) at http://home.netscape.com.</IFRAME></P>
              </TD>
    try that, it should work... hopefully

  5. #5
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Tokyo
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    thanks!

    thank you, worked like a charm!
    kurt

  6. #6
    long gone but not forgotten AljapaCo's Avatar
    Join Date
    Aug 2001
    Location
    Sweden
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    small note to that one...

    specify the vertical align in the <tr> tag and the lateral align in the <td> tag.

    Itīs a nice practice and if you have several tdīs in on line, you only need to specify the valign once!!
    T O B I A S - S T R A N D H | visit my site here
    OPERA7 /MSIE6 /FireFox 1.1/Win2000 /ADSL /17" Screen /1024x768
    god doesn't create genius, he clones me.............


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •