SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Addict
    Join Date
    Jul 2008
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Strange aliginment issue on I.E.

    Hi everybody, I've posted this to the wrong section+ cant delete, should be in CSS.
    I'm new to this, so i bet this is simple or silly,

    This site appears ok in Firefox, but not on I.E. , its the username and password bit at the top that is out of line on I.E., can anybody show me what I'm doing wrong?

    the site is at

    http://www.jointheclub.ie/index.php

    thanks
    Last edited by livewire1974; Nov 23, 2008 at 06:10. Reason: wrong section

  2. #2
    SitePoint Wizard bronze trophy Centauri's Avatar
    Join Date
    May 2007
    Location
    Newcastle, Australia
    Posts
    3,718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try removing the div that surrounds the submit button.

  3. #3
    SitePoint Addict
    Join Date
    Jul 2008
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Centauri View Post
    Try removing the div that surrounds the submit button.
    Tried it, still the same....

  4. #4
    SitePoint Wizard bronze trophy Centauri's Avatar
    Join Date
    May 2007
    Location
    Newcastle, Australia
    Posts
    3,718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The form closing tag is overlapping two closing div tags - the form closing needs to be moved to just after the .forgotp div :
    Code:
        <div class="interface">
    	<form action="" method="post">
          <div class="usernamebg">
            <div class="username">Username</div>
    
            <div class="textfield">
                <input name="username" class="field"  type="text" />
            </div>
          </div>
          <div class="usernamebg">
            <div class="username">Password</div>
            <div class="textfield">
                <input name="password" class="field"  type="password" />
    
            </div>
          </div>
          <input type="image" name="loginbutton" img src="images/submit.jpg"  width="67" height="25" border="0" />
    	<div class="forgotp"><a href="forgot.php"> Forgot password? Click here</a></div> 
    	</form>	
       </div>
    	
      </div>

  5. #5
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    Let's line up that code so that it's easier to tell what's going on there.

    Code html4strict:
    <div class="interface">
        <form action="" method="post">
            <div class="usernamebg">
                <div class="username">Username</div>
                <div class="textfield">
                    <input name="username" class="field"  type="text" />
                </div>
            </div>
            <div class="usernamebg">
                <div class="username">Password</div>
                <div class="textfield">
                    <input name="password" class="field"  type="password" />
                </div>
            </div>
            <input type="image" name="loginbutton" img src="images/submit.jpg"  width="67" height="25" border="0" />
            <div class="forgotp"><a href="forgot.php"> Forgot password? Click here</a></div>
        </form>	
    </div>
    <!-- extra /div removed -->
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  6. #6
    SitePoint Addict
    Join Date
    Jul 2008
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks guys, tried the suggestions, neither work....is there something else i can do?

  7. #7
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,729
    Mentioned
    104 Post(s)
    Tagged
    4 Thread(s)
    Yes, someone could actually take a copy of it and play around wit it to find out what the problem actually is. I'll take a look at it now.

    My first suspicion before even starting to look is that it's CSS to blame.

    Edit: I was right. The mystyle.css file has a strange line that goes:

    Code css:
    *width:;

    Which when removed fixes the problem, in IE7 anyway, and creates another one where the "forgot password" text wraps in IE.

    I suggest moving this along to the css forum where experts can be of great help to you with this issue.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  8. #8
    SitePoint Addict
    Join Date
    Jul 2008
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pmw57 View Post
    Yes, someone could actually take a copy of it and play around wit it to find out what the problem actually is. I'll take a look at it now.

    My first suspicion before even starting to look is that it's CSS to blame.
    yes, its def the CSS, i'm looking @ it also, but new to CSS so its slow...

  9. #9
    SitePoint Wizard bronze trophy Centauri's Avatar
    Join Date
    May 2007
    Location
    Newcastle, Australia
    Posts
    3,718
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seems to be ok now.

  10. #10
    SitePoint Addict
    Join Date
    Jul 2008
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Centauri View Post
    Seems to be ok now.

    yup. eventually fixed it, more by luck than anything!!!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •