SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast
    Join Date
    May 2008
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Embedding a video in IE

    I have a .wmv video that I am embedding into a page on a site I'm making..

    In FF it displays perfectly, however in IE there is a browser warning at the top about trusting the site yada yada...is there a way to embed the video to avoid that warning so it just plays in IE??

    The video:
    http://tinyurl.com/5hq4bs


    Thanks in advance for any help with this.

  2. #2
    Now available in Orange Tijmen's Avatar
    Join Date
    Jul 2004
    Location
    The Netherlands
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I used to have lots of issues like that as well. Now I always convert video to a flv file in Flash and its works fine cross-browser
    Travel Photos on Flickr - Twitter

    “Never give up. Never surrender”

  3. #3
    SitePoint Enthusiast
    Join Date
    May 2008
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Tijmen View Post
    I used to have lots of issues like that as well. Now I always convert video to a flv file in Flash and its works fine cross-browser
    I have converted it to .flv and am trying to do the same thing, but I'm still getting warnings in IE.

    Can you post a sample of the code you're using to display the flv without the warning in IE please?? Thanks!

  4. #4
    Now available in Orange Tijmen's Avatar
    Join Date
    Jul 2004
    Location
    The Netherlands
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you have an url with the flash video? The one above only shows the wmv file. And when I watch it in IE7 it works works fine for me without any warnings.

    And did you maybe change your security settings in your browser to a higher level?
    Travel Photos on Flickr - Twitter

    “Never give up. Never surrender”

  5. #5
    SitePoint Enthusiast
    Join Date
    May 2008
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    my latest rendition, which actually uses the MC Media player (which by itself works flawlessly, without warnings, in IE) causes IE to crash when I put it into the AJAX intended to display the video.

    Heres the link:
    http://tinyurl.com/68s6gr


    click on the 'rarely thought about' in the right column...

    each element (my AJAX, and the video) work perfectly on their own. Just when I combine them that the world blows up.


    ahh why won't IE die already so I can just design my pages for FF....where, btw, it worked flawless with pretty much with all 20 setups I tried to make work with IE..

  6. #6
    Now available in Orange Tijmen's Avatar
    Join Date
    Jul 2004
    Location
    The Netherlands
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My guess would be thats there's something wrong with the JavaScript that makes IE crash. JavaScript isn't really my thing, so you would be better of posting that in the JavaScript section.

    At work we use lightview for things like this. And that works fine in all browsers
    Travel Photos on Flickr - Twitter

    “Never give up. Never surrender”


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •