SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot
    Join Date
    Dec 2005
    Posts
    119
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't login on virtual host with IE

    Hi,

    I am able to log in in Firefox with a php script but not in IE on a virtual host. Is there something in IE that is not allowing this or is there something that I am missing?

    Thanks.

  2. #2
    Web Professional
    Join Date
    Oct 2008
    Location
    London
    Posts
    862
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What do you mean by "log in"?

  3. #3
    SitePoint Zealot
    Join Date
    Dec 2005
    Posts
    119
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Paul,
    Sorry, I wasn't very clear.

    I have a login script on the site that you helped me set up last night where you can access the "My Account" area. I can login just fine on Firefox with it but not on IE. Any ideas why this would be?

  4. #4
    SitePoint Zealot
    Join Date
    Dec 2005
    Posts
    119
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I should add that it works fine when I upload it to a web host and try to log in on IE.

  5. #5
    Web Professional
    Join Date
    Oct 2008
    Location
    London
    Posts
    862
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hard to tell from what you've said. Are you using sessions?

  6. #6
    SitePoint Zealot
    Join Date
    Dec 2005
    Posts
    119
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes.

    I thought maybe there might be something with privacy settings in IE but that doesn't seem to affect anything.

    Actually, no sessions are being stored.

    I'll keep searching, just thought this might be something stupid that I'm not seeing.

  7. #7
    SitePoint Zealot
    Join Date
    Dec 2005
    Posts
    119
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just thought I would post here what I did and it works.

    I found in one of the postings in the php manual that you can't have _ in the name of your site on a virtual host for IE to view it as a safe domain. I took out the _'s and now it's fine.

    Interesting, huh?
    Last edited by affmark; Nov 15, 2008 at 16:46. Reason: Bad Typist


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •