SitePoint Sponsor

User Tag List

Results 1 to 7 of 7

Hybrid View

  1. #1
    SitePoint Zealot
    Join Date
    Mar 2007
    Posts
    182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Wordpress - Custom Permalinks causes post to not be displayed

    I'm leaning how to use wordpress.

    On the tutorial on writing a post, there is s section on Permalinks. I changed it from default to custom (/%category%/%postname%/).

    But before i changed the permalinks, i already wrote a post.

    When i wrote my post in the dashboard under the write --> post, i created a new category (add new category) and then ticked on it. So i assume my new post will be under the category. I also went to manage--> category and deleted the category called Uncategorized. So the homepage does not have Uncategorized.

    I have already posted my sample article (this is a wordpress thats running on a local machine - WAMP).

    After changing to a custom permalink, i tried to go to the homepage of my blog and click on my post that i wrote and published earlier but i seem to get an error.

    Error: Not Found

    The requested URL /lovetowrite/uncategorized/this-is-my-first-article/ was not found on this server.

    Please help me coz i cant seem to view my post now ever since i changed the permalinks.

    Thanking you in advanced,
    Kenneth Jaysone Francis

  2. #2
    SitePoint Wizard ryanhellyer's Avatar
    Join Date
    Oct 2006
    Location
    New Zealand
    Posts
    2,323
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't think you can use %category%/%postname%/ as your permalinks as if you have more than one category, the post would have two different permalinks. I haven't checked this though, it's just an assumption.

    Does the post appear if you change to another permalink setup?

  3. #3
    SitePoint Addict
    Join Date
    Mar 2006
    Posts
    367
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ryanhellyer View Post
    I don't think you can use %category%/%postname%/ as your permalinks as if you have more than one category, the post would have two different permalinks. I haven't checked this though, it's just an assumption.
    You can. WordPress will use one category in the permalink. I believe it is whatever one has the smallest ID.

  4. #4
    SitePoint Wizard ryanhellyer's Avatar
    Join Date
    Oct 2006
    Location
    New Zealand
    Posts
    2,323
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I guess it just goofed up when the category was removed.

    Perhaps try changing permalinks, then going back to your original setup. Maybe it will autocorrect itself.

  5. #5
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    This is also just a hypothesis, as I have never used WAMP but I know using WP/XAMPP that you have to enable something to make the .htaccess file work locally. Maybe this is the same issue you are having with WAMP.

  6. #6
    SitePoint Wizard ryanhellyer's Avatar
    Join Date
    Oct 2006
    Location
    New Zealand
    Posts
    2,323
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by BPartch View Post
    This is also just a hypothesis, as I have never used WAMP but I know using WP/XAMPP that you have to enable something to make the .htaccess file work locally. Maybe this is the same issue you are having with WAMP.
    I use XAMPP Lite but have never needed to do anything to enable .htaccess. Perhaps you are meaning ModRewrite? ModRewrite does need to be set up manually.

  7. #7
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ryanhellyer View Post
    I use XAMPP Lite but have never needed to do anything to enable .htaccess. Perhaps you are meaning ModRewrite? ModRewrite does need to be set up manually.
    You may be right!

    Though it had to do with the permalinks and after I made the change my permalinks worked. I found it here a few years ago: http://www.tamba2.org.uk/wordpress/xampp/


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •