SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Threaded View

  1. #1
    Avid Logophile silver trophy
    ParkinT's Avatar
    Join Date
    May 2006
    Central Florida
    192 Post(s)
    5 Thread(s)

    Rake 'require' error on VPS

    First, I have scoured the Internet for days and this problem is plaguing me. I need help from someone with Ruby on Rails experience on a VPS.

    I have always developed rails apps on shared hosting. For the first time I have a "hands on" (physical) internal server I need to use for deploying a proprietary RoR app.

    After installing Ruby, installing rails, installing MySQL, setting up Apache2 I have proven my Ubuntu Server is working as expected.
    The command 'rails <appname>' worked perfectly.

    Next I tried running rake.
    I got this error:
    /usr/bin/rake:27 'require' : no such file to load -- (LoadError) rake
    Hopefully, you can guide me on how to overcome this stumbling block. It is the last thing that stands in my way to success on this project (which, of course, has a tight deadline).
    {btw: the rake file is only 28 lines long. It simply calls this include then calls }

    Reading on the Internet, I see a change in Ruby 1.8.6 and Ruby 1.9 with respect to how gems are handled.
    I was unsuccessful as installing Ruby 1.9 on this box. But I really don't believe that is the fix for my problem.

    Thanks in advance.
    Last edited by ParkinT; Oct 29, 2008 at 10:52.
    Don't be yourself. Be someone a little nicer. -Mignon McLaughlin, journalist and author (1913-1983)

    Git is for EVERYONE
    Literally, the best app for readers.
    Make Your P@ssw0rd Secure
    Leveraging SubDomains


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts