SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Zealot
    Join Date
    Jul 2008
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Special characters in filename

    Hi all,

    I am trying to link to the following filename:

    uk-high-street-banks-own-£95bn-assets-that-could-qualify-for-us-financial-package.php

    If I try to follow a link to the above, I get a page not found error "The requested URL /treasury-must-guarantee-�40bn-of-assets-to-sell-off-Bradford-and-Bingley.php was not found on this server."

    In order to get this to work, I am replacing the '£' symbol for £ which seems to work fine when I upload to my server.

    The problem is that this link doesn't work in my WAMP localhost environment and instead I get the error "Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0"

    Can anyone please tell me the correct way to replace £ symbol for use in URLs.

  2. #2
    SitePoint Author silver trophybronze trophy

    Join Date
    Nov 2004
    Location
    Ankh-Morpork
    Posts
    12,158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try uk-high-street-banks-own-%A395bn-assets-that-could-qualify-for-us-financial-package.php
    Birnam wood is come to Dunsinane

  3. #3
    SitePoint Zealot
    Join Date
    Jul 2008
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, Thanks for the fast reply.

    I tried using %A3 instead but now I get a 404 Forbidden error page on my WAMP server. If I upload to main server, %A3 works.

    Do you think there's a setting in my WAMP config to allow these types of URL?

  4. #4
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Use better URLs? I go cross eye trying to read that long long long file name...
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  5. #5
    SitePoint Zealot
    Join Date
    Jul 2008
    Posts
    188
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi logic_earth. The reason I've made the filename long is because it is an article of which I have hundreds. The article title is derived from the url and so it needs to be like this.

    I'm pretty convinced this is a problem with a setting in my WAMP server as everything works fine when I upload to my main server. If I type in the url directly for WAMP, the same error message appears so it can't be a problem with the link itself.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •