SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Apr 2005
    0 Post(s)
    0 Thread(s)

    Errors installing Readline

    Hi guys,
    I'm trying to install RoR on OS X Leopard as described in Simply Rails 2 by Patrick Lenz.

    I receive the following errors when I attempt to install Readline:
    make[1]: *** [libreadline.5.2.dylib] Error 1
    make: [shared] Error 2 (ignored)
    I have googled for possible solutions but I haven't found anything that works. I have Xcode installed and I have setup my paths correctly.

    Any ideas?

  2. #2
    SitePoint Addict
    Join Date
    Feb 2007
    0 Post(s)
    0 Thread(s)
    I'm afraid I worked off the earlier edition of his book, but did you try this?

    curl -O
    tar xzvf readline-5.2.tar.gz
    cd readline-5.2
    curl -O
    patch -p0 < readline52-012
    ./configure --prefix=/usr/local
    sudo make install
    This should download and install the latest version of readline for Leopard.

    Note to all posters: For the benefit of those who don't have a particular book you have problems with, it would help to post what you did that didn't work. Few of us can afford every edition of every tech book that gets published, and for those that know the book in question, it serves as a double-check that you actually *were* following the book in the first place.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts