SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Empire-Forums
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    background/table problem

    I am tryed to put a background image in one tables. The bg image itself is 25X1 but when I put in in the table for some reason it loops for only 2 pixels of the bgimage. I have a image attached to show what I mean.

    PHP Code:
    <table cellpadding="0" cellspacing="0" border="0" width="100"><tr>
    <
    td width="96" background="images/catbg.gif">
    <
    img src="images/catleft.gif">
    </
    td>

      <
    td width="90%" valign="top" background="images/catbg.gif" align="center">
    <
    b>title</b></td>

    <
    td width="96" background="images/catbg.gif">
    <
    img src="images/catright.gif">
    </
    td>
    </
    tr></table
    I also have to images on the sides of it... but for some reason I cant seem to get it. can any give me a insight?

    Thanks.
    Attached Images Attached Images

  2. #2
    SitePoint Wizard
    Join Date
    Jul 2001
    Location
    The Netherlands
    Posts
    2,617
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You said the image was 25x1. Is the 25 the height or the width? If it is the height, the problem might be there. You need to define a height in the table cell as well, because it usually won't wrap around the background image.

  3. #3
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Empire-Forums
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    25 is the height.. but the odd thing is when the bg was 23X1 it did the same thing and when I try to use height it doesnt to a thing :\

    Note: I am working with vb templates


    I also took out the two side images and then it seemd to work fine.. but I need to have the images there so I have no clue why its not workig even if I *** height tags to it
    Last edited by Eternity; Apr 25, 2002 at 15:42.

  4. #4
    SitePoint Guru sowen's Avatar
    Join Date
    Feb 2001
    Location
    Stockport, UK
    Posts
    729
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try a spacer.gif (1px x 1px transparent) put it in the table cell and set it's height to 25px see if that works.
    Code:
    <img src="images/spacer.gif height="25">

  5. #5
    SitePoint Member
    Join Date
    Apr 2002
    Location
    Empire-Forums
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i get the same thing and it makes it worse ><
    I just dont understand...

  6. #6
    .net install meltdown
    Join Date
    May 2001
    Location
    View Ridge
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry, but I'm not following along.

    Have you got a link we can check out?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •