SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Zealot
    Join Date
    Mar 2005
    0 Post(s)
    0 Thread(s)

    no comments to post-->markup looks bad


    when there are comments to the post the site look: (look at the bottom)

    when there are NO comments the site look: (look at the bottom)

    seems like divs are missing and the markup gets screwed up

    can u help to fix it?


  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    West Springfield, Massachusetts
    198 Post(s)
    3 Thread(s)
    It's hard to say what's going on.

    The "with comments" page, rifinitura-e-convocati-vs-argentia, has 59 Errors, 1 warning(s)

    The "without comments" page, marcatori, has 56 Errors, 1 warning(s)

    This could be caused by WordPress itself (not probable), the theme you're using, or the plugins you're using.

    To narrow things down, try validating the pages using a WordPress theme (classic or default) with all the plugins disabled. If that passes validation, try your theme again and try validating again. If that passes re-enable your plugins one-by-one until it fails. Once you know what's causing the mark-up errors, you'll be able to figure out if you need to make changes to your CSS.

    A lot of testing I know, but it's really the only way to solve the problem without a ton of hit-or-miss (usually miss) fix attempts.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts