SitePoint Sponsor

User Tag List

Results 1 to 17 of 17
  1. #1
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    Music with flash equalizer only plays when on-screen?

    Music with flash equalizer only plays when on-screen? When it's off-screen (i.e. on longer pages, and below the bottom of the browser window) it doesn't start playing until you scroll down so it's on-screen - and then it starts playing. I don't know how I didn't notice it before - Hmmm? IE is the only one that plays it regardless if it's on or off-screen - FX, Opera, and Safari do not. Is this just a trait of Flash/Music or is there a fix for this? Thanks for any thoughts!

    Here is the site in question. See how it plays on the home page? But then go to the "How To page" for instance and you'll see that it does not! http://www.ericwwatson.com

  2. #2
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This may be a browser based issue -- i have noticed the same on myspace, say you open up a few myspace websites, the flash on the page may only play when the tab is active.

    This is probably a way for the browser to manage its own resouces, as FF was known to have its resources expand and cause the browser to crash. In a sililar issue, with a player at the bottom of a page, it might be because of these same constraints.

    Perhaps you could try loading the flash player in an iframe at the bottom of your page? I havent tested it, but good luck.

  3. #3
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the idea! But I just tried the iframe and no-go! Anymore ideas anybody?

  4. #4
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    did you purchase the flash MP3 player or make it yourself? it may have code in it to prevent it from playing unless its in the field of view of the browser.. ??

    in theory, you should be able to create a small flash .SWF file that plays a mp3 by dragging the file into the timeline.. this should work on its own, which leads me to wonder if its not functionality built into your Flash MP3 player

  5. #5
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ripcurlksm View Post
    did you purchase the flash MP3 player or make it yourself? it may have code in it to prevent it from playing unless its in the field of view of the browser.. ??

    in theory, you should be able to create a small flash .SWF file that plays a mp3 by dragging the file into the timeline.. this should work on its own, which leads me to wonder if its not functionality built into your Flash MP3 player
    Nice Avitar! Ya I bought it, and I don't have a Flash editor so I have no idea whats in there.

  6. #6
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok well this may be your problem to start with.. your problem/solution lies in the actionscript of your flash file. You may want to contact the developer and ask them about it.

  7. #7
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    ok well this may be your problem to start with.. your problem/solution lies in the actionscript of your flash file. You may want to contact the developer and ask them about it.
    I put a question in to the forum where I purchased it (Flash Den http://www.flashden.net/item/simple-...equalizer/6598), so we'll see... Only I don't think that's the problem. Otherwise, it would most likely behave that way in all browsers. But as we know, IE plays it regardless if it's on screen or not.

    P.S. – I already tried putting it in an iframe – no go! And I already tried putting the code at the top of the wrapper and positioning the “object” tag absolutely at the bottom – no go! Ideas???

  8. #8
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have purchased a flash player as well from flash den (as seen on my band homepage http://psylicyde.com ) and this player has the same functionality so i figured I would ask.

    There is no solution you can have outside of tweaking the actionscript in the flash file.

  9. #9
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ripcurlksm View Post
    I have purchased a flash player as well from flash den (as seen on my band homepage http://psylicyde.com ) and this player has the same functionality so i figured I would ask.

    There is no solution you can have outside of tweaking the actionscript in the flash file.
    Thanks for the info! Anybody know how to tweak the swf so it plays on-screen or off-screen?

  10. #10
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    do you have flash? can you post the actionscript?

  11. #11
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ripcurlksm View Post
    do you have flash? can you post the actionscript?
    No unfortunately I do not have flash - so sad :~(

  12. #12
    SitePoint Guru krityx's Avatar
    Join Date
    Jan 2006
    Location
    Around
    Posts
    634
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    this is NOT an actionscript issue for sure. I've checked the AS and there's nothing to stop it from playing. I'm 99,99% sure this is a browser problem. The browser doesn't start the flash file unless it is on screen and that's just how it is ... I don't know of any fixes though
    Last edited by krityx; Oct 14, 2008 at 16:04. Reason: grammar


  13. #13
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Overall, I think it is a good policy

  14. #14
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Hi Adrian! I'm still at it!

    and that's just how it is ...
    Thats good if it's true - then I can wash my hands of this and move on. I thought forsure if I put the code up-top it would then play it. But somehow the browser knows exactly what I see and when I see it.

  15. #15
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    This was the problem right here <param name=wmode value=transparent> Remove it and it works perfect!

  16. #16
    SitePoint Guru ripcurlksm's Avatar
    Join Date
    Aug 2004
    Location
    San Clemente, CA
    Posts
    857
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    /slaps forehead

  17. #17
    SitePoint Wizard bronze trophy PicnicTutorials's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, California, United States
    Posts
    3,623
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Me too! Someone else brought that to my attention - I can't take credit for it. Well, now we know. And everybody else in the world also. This is the only thread of it's kind - trust me I looked!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •