Hello,
I'm trying to get the backbone of a rails project up and running on localhost and also on a rails playground hosted site.

On localhost the app runs great and I can call my say/hello w/ either: http://localhost:3000/controller/say/hello or http://localhost:3000/say/hello,

but when I try this on my rails playground site I get this when I call the say/hello like this: http://erichermann.com/say/hello:

ActionView::MissingTemplate (Missing template say/hello.html.erb in view path /home/c73mr0ck/railsapp/app/views):
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_view/template.rb:85:in `raise_missing_template_exception'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_view/template.rb:78:in `set_extension_and_file_name'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_view/template.rb:15:in `initialize'

And I get this when I call the say/hello like this: http://erichermann.com/controller/say/hello:

ActionController::RoutingError (No route matches "/controller/say/hello" with {:method=>:get}):
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/routing/recognition_optimisation.rb:67:in `recognize_path'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/routing/route_set.rb:384:in `recognize'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:148:in `handle_request'
ect.


My controller code looks like this

Code:
class SayController < ApplicationController
  def hello
  end
end
And my routes.rb code looks like this:
Code:
ActionController::Routing::Routes.draw do |map|
  map.connect ':controller/:action/:id'
  map.connect ':controller/:action/:id.:format'
end
One thing that could be causing a big problem is that on localhost, my rails version is: Rails 1.2.6

and on the Rails Playground hosting the version is: Rails 2.1.1

Any ideas how I can get this to work in both places?

Thanks,
Clem