SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Zealot unformatik's Avatar
    Join Date
    Aug 2007
    Location
    216/GMT+1
    Posts
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    404 Error, Permalink in WordPress.

    Hi Friends,

    I have just setup WordPress. In settings > Permalink I have selected Custom structure: /%category%/%postname%/ to change http://www.domain.ltd/?p=123 to http://www.domain.ltd/category/postname. The surprise is an 404 Error

    Any idea to fix it, thanks

  2. #2
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Check the .htaccess file in the root of your WP install, make sure it has something like this in it.
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  3. #3
    SitePoint Zealot unformatik's Avatar
    Join Date
    Aug 2007
    Location
    216/GMT+1
    Posts
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by BPartch View Post
    Check the .htaccess file in the root of your WP install, make sure it has something like this in it.
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    I have this code


    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /services/

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /services/index.php [L]

    </IfModule>


    # END WordPress

  4. #4
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Is your blog installed in a directory named services?

  5. #5
    SitePoint Zealot unformatik's Avatar
    Join Date
    Aug 2007
    Location
    216/GMT+1
    Posts
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by BPartch View Post
    Is your blog installed in a directory named services?
    yes

  6. #6
    SitePoint Zealot unformatik's Avatar
    Join Date
    Aug 2007
    Location
    216/GMT+1
    Posts
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    when I add ? after installation path, the permalinks works


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •